Bug 182 - pan_onccN and lfoN_pan
Summary: pan_onccN and lfoN_pan
Status: ASSIGNED
Alias: None
Product: LinuxSampler
Classification: Unclassified
Component: other (show other bugs)
Version: unspecified
Hardware: PC Linux
: P5 normal
Assignee: Andreas Persson
URL:
Depends on:
Blocks:
 
Reported: 2012-07-16 13:05 CEST by Nicola Pandini
Modified: 2016-07-07 12:54 CEST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicola Pandini 2012-07-16 13:05:12 CEST
Using these opcodes, it's not possible to reach an "all to left" or "all to right" panning.

example:
pan_oncc9=100

when I send a cc9=0, channels output are:  Left -3.4db, Right -3.4db
when I send a cc9=127, channels output are:  Left -3.6db, Right -3.2db

same results with:
lfo16_freq=0.00001
lfo16_wave=0
lfo16_pan=100
lfo16_phase=0
lfo16_phase_oncc9=90 (hard right)

I tried with mono and stereo files.

thanks
Comment 1 luckylud 2016-07-07 12:54:01 CEST
This is working now with :
pan=-100 pan_onccx=200

Pan Left (-100) :   0 ccx
Pan Right (100) : 127 ccx

This bug can be closed as fixed or not a bug ?