Bug 301 - notes do not play if they're placed one after other
Summary: notes do not play if they're placed one after other
Status: ASSIGNED
Alias: None
Product: LinuxSampler
Classification: Unclassified
Component: other (show other bugs)
Version: 2.0.0
Hardware: PC Linux
: P5 major
Assignee: Christian Schoenebeck
URL:
Depends on:
Blocks:
 
Reported: 2016-12-02 02:42 CET by Vladislav
Modified: 2017-02-14 15:16 CET (History)
0 users

See Also:


Attachments
audio bug_linuxsampler_what_we_have (146.03 KB, audio/mpeg)
2016-12-02 02:42 CET, Vladislav
Details
audio bug_linuxsampler_what_we_wait (183.05 KB, audio/mpeg)
2016-12-02 02:42 CET, Vladislav
Details
screenshot 1 - notes (168.13 KB, image/png)
2016-12-02 02:43 CET, Vladislav
Details
screenshot 2 - connection to LMMS (121.01 KB, image/png)
2016-12-02 02:43 CET, Vladislav
Details
screenshot 3 - Fantasia GUI (229.50 KB, image/png)
2016-12-02 02:44 CET, Vladislav
Details
screenshot 4 - sfz file (301.91 KB, image/png)
2016-12-02 02:44 CET, Vladislav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav 2016-12-02 02:42:11 CET
Created attachment 79 [details]
audio bug_linuxsampler_what_we_have

Hello dear friends.

I found this bug many time earlier, it prevents me from writing music - I cannot finish my track, so I give it severity "major".

Bug:
Only the first of notes play in such sequence of notes (screenshot 1) (<bug_linuxsampler_what_we_have.mp3>).
But expected that must play something like this: <bug_linuxsampler_what_we_wait.mp3>.

How do I configured sampler:
With Jack I connected notes from LMMS's Piano Roll to Linux Sampler (screenshot 2).
Instrument was loaded with Fantasia GUI (screenshot 3).
Example of .sfz file is on screenshot 4.
Full file was attached to file exchanging service (I'll try to attach it here after publishing).

I use Debian unstable x64. Linuxsampler 2.0. LMMS 1.3, Fantasia GUI 0.9.


So as I cannot add here several attachments - I'll upload them on vk.com:
screenshot 1 - notes: https://pp.vk.me/c837525/v837525447/10c5f/NY-Eyo9JeBc.jpg
screenshot 2 - connection to LMMS: https://pp.vk.me/c837525/v837525447/10c68/KKo9zthbdVk.jpg
screenshot 3 - Fantasia GUI: https://pp.vk.me/c837525/v837525447/10c71/KUwelXyEubA.jpg
screenshot 4 - sfz file: https://pp.vk.me/c837525/v837525447/10c7a/Sn-In_Kpi4U.jpg

audio bug_linuxsampler_what_we_have: https://vk.com/search?c[q]=bug_linuxsampler_what_we_have&c[section]=audio&c[performer]=1
audio bug_linuxsampler_what_we_wait: https://vk.com/search?c[q]=bug_linuxsampler_what_we_wait&c[section]=audio&c[performer]=1
(maybe there would be problems with playing audio to non-registered users, so I attach here "what we have" file and will send my login and password to authorize on vk.com (I'll send only to Linux Sampler developers))

.sfz instrument with samples: https://vk.com/doc16425447_439489177


I would be glad if you'll correct it.

Best wishes,
Vladislav
Comment 1 Vladislav 2016-12-02 02:42:55 CET
Created attachment 80 [details]
audio bug_linuxsampler_what_we_wait
Comment 2 Vladislav 2016-12-02 02:43:42 CET
Created attachment 81 [details]
screenshot 1 - notes
Comment 3 Vladislav 2016-12-02 02:43:58 CET
Created attachment 82 [details]
screenshot 2 - connection to LMMS
Comment 4 Vladislav 2016-12-02 02:44:14 CET
Created attachment 83 [details]
screenshot 3 - Fantasia GUI
Comment 5 Vladislav 2016-12-02 02:44:30 CET
Created attachment 84 [details]
screenshot 4 - sfz file
Comment 6 Vladislav 2016-12-02 02:46:00 CET
So as appeared way to add attachments after I posted bug in separate messages and there is no possibility to edit bug message, I added them commented below.

Thanks.
Comment 7 Christian Schoenebeck 2017-01-03 13:22:16 CET
And you think there is a bug where exactly? In the implementation of some specific SFZ opcode? Driver? LinuxSampler setting?

In general please always provide a stripped down version i.e. of the the sfz file that demonstrates the misbehavior you encounter, remove all unnecessary aspects not related to the issue, then attach it as text file to the report.
Comment 8 Vladislav 2017-01-03 19:15:01 CET
Hello Christian.

I don't know the code of Linux Sampler, sorry, I cannot tell you where the bug is.
You can download full instrument, which produces bug here: http://bugs.linuxsampler.org/cgi-bin/attachment.cgi?id=84 , I write it in comment, because I could not change first message.
Comment 9 Vladislav 2017-01-03 19:18:06 CET
Also you can download all my .sfz files here: https://vk.com/doc16425447_438349237
Comment 10 Christian Schoenebeck 2017-01-03 19:34:09 CET
I was not talking about LinuxSampler code, I was talking about SFZ opcodes (the elements of the SFZ file format) and suggested to you to upload a stripped down (small) version of the SFZ file that causes the misbehavior.

Or in other words: Even if you don't know how to code in C++, you can still play around with the SFZ file for instance and check what exactly in the SFZ file is triggering the misbehavior.

That will largely increase the chance that your bug reports will be addressed.
Comment 11 Christian Schoenebeck 2017-02-14 15:16:35 CET
Please checkout the latest SVN version of LinuxSampler. I am optimistic that it fixes this issue. See also bug 302.